Ubuntu nelze použít klávesové zkratky IntelliJ IDEA

118

Jsem pro Ubuntu velmi nová a mám problém, že nevím, jak to opravit. Dokonce jsem se snažil hledat na webu odpovědi, ale možná nevím, jaké jsou správné podmínky pro vyhledávání.

Pracuji s IntelliJ IDEA , což je aplikace pro vývoj. A jsem velmi zvyklý na klávesové zkratky, ale když jsem přepínal ze systému Windows XP na Ubuntu 13.10, některé zkratky už nefungují. Například jako například

  • Ctrl + Alt + <
  • Alt + F8

Existuje nějaký důvod, proč? a existuje nějaká oprava pro toto? Nebo možná jen něco, co mě vede při mém hledání

Děkuji všem v předstihu.

    
dané Rodrigo Sasaki 28.01.2014 13:01

10 odpovědí

188

Jako trochu čtení mě naučil, že Intellij IDEA je klávesnice IDE. Co to znamená, že s ním může pracovat bez toho, aby se musel dotknout myši. Také se mi podaří najít nastavení klávesnice.

Ubuntu

Přečtěte si jak změnit klávesové zkratky?

Zde je seznam vylepšení, které je třeba provést s výchozími vazbami systémových klíčů, takže nebudou zasahovat do akcí IntelliJ IDEA (uvedených v závorkách).

  
  • Zakažte akci okna Shade, která je přiřazena Ctrl + Alt + S   
  • Změna nebo zakázání akce uzamčení obrazovky, přiřazené Ctrl + Alt + L   
  • Změňte nebo deaktivujte akci Terminálu spouštění, přiřazenou Ctrl + Alt + T   
  • Změňte nebo deaktivujte akci Přepnout na pracovní plochu přidělenou klávesám Ctrl + Alt + Šipky   
  • Zakažte akci Přesunout okno, přiřazené Alt + F7
  •   
  • Změňte nebo deaktivujte akci okna Změnit velikost, přiřazenou Alt + F8 (Vyhodnotit výraz)
  •   

Doufám, že to pomůže!

Poznámka: Klávesové zkratky Ubuntu můžete vždy vrátit zpět do výchozího stavu. Stačí se podívat na Jak mohu obnovit výchozí klávesové zkratky? , v případě ztráty .

Zdroj: - Intellij IDEA Keymap

    
odpověděl AzkerM 28.01.2014 13:39
28

Přišel jsem do tohoto problému také, ale mé řešení bylo jiné.

Nevyžaduje se ani nepotřebujete změnu systémového mapového klíče

IntelliJ má různé klávesové zkratky, které můžete změnit podle operačního systému.

Z nastavení můžete změnit klíčová karta IntelliJ .

Stačí přejít naSettings -> Keymap a z rozbalovací nabídky vyberte požadovanou klávesovou mapu. V mém případě jsem zvolil "Výchozí nastavení pro GNOME", protože používám Ubuntu Gnome 16.04.

    
odpověděl Francisco C. 25.06.2016 07:18
14

Pro ubuntu 18.04 LTS ctrl + alt + vlevo (konflikt zástupce myšlenky Intellij)

  • nainstalujte Dconf Editor do softwaru ubuntu
  • spusťte editor Dconf, přejděte na / org / gnome / desktop / wm / keybindings / přepnutí do pracovního prostoru-left

  • Dvakrát klikněte na tlačítko

  • použijte výchozí hodnotu (klikněte na Vypnuto) - > Vlastní hodnota (jako já nebo jinde)

  • můžete jej použít v ideji intellij nyní

    
odpověděl think 06.05.2018 11:42
5

Vytvořil (a) jsem tento skript, který vypíná všechny zkreslené zkratky mezi Ubuntu (testováno s 15.10) a IntelliJ (a pravděpodobně více produktů Jetbrains). Zakáže je v Ubuntu.

Vytvoří také záložní soubor, který vám umožní obnovit předchozí nastavení.

Chcete-li zakázat některé zástupce, napište je do poleKEYS.

#!/bin/bash
set -euo pipefail

# Disables Ubuntu shortcuts that clash with IntelliJ Idea (and probably other
# Jetbrain products).
#
# Creates a backup file to restore the previous settings. To not have some
# shortcuts disabled, comment them out in the 'KEYS' array.
#
# Tested on : Ubuntu 15.10
# Author    : Jonas Gröger

readonly BACKUP_FILE="undo-fix-shortcuts-$(date +%s%N).sh"
readonly KEYS=(
    "/org/gnome/desktop/wm/keybindings/toggle-shaded"
    "/org/gnome/settings-daemon/plugins/media-keys/screensaver"
    "/org/gnome/settings-daemon/plugins/media-keys/terminal"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-down"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-up"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-left"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-right"
    "/org/gnome/desktop/wm/keybindings/begin-move"
    "/org/gnome/desktop/wm/keybindings/begin-resize"
    # To disable resetting a value, just comment out the line
)
readonly DISABLED_VALUE="['disabled']"

main() {
    # Make backup
    printf "#!/bin/bash\n" >>  "$BACKUP_FILE"
    for key in "${KEYS[@]}"; do
        local value
        value=$(dconf read "$key")
        printf "dconf write \"%s\" \"%s\"\n" "$key" "$value" >> "$BACKUP_FILE"
    done

    # Disable all Ubuntu shortcuts
    for key in "${KEYS[@]}"; do
        dconf write "$key" "$DISABLED_VALUE"
    done
}
main

Zde můžete získat:

wget -O fix-shortcuts.sh https://gist.githubusercontent.com/JonasGroeger/94cfa1071fa12572f465/raw/fix-shortcuts.sh
    
odpověděl Jonas Gröger 16.12.2015 22:40
3

Projděte si zde způsob, jak zaktivovat skratky Ubuntu programově a pouze v případě, že jsou aktivní okna určitých aplikací.

Konkrétně použijte tyto hodnoty (za předpokladu, že používáte JetBrains Toolbox s jeho standardní instalační cestou, jinak se přizpůsobte):

apppattern = "JetBrains"
backupfile = "~/.local/share/JetBrains/keymap_backup"

Zatímco skript běží, zkratky Ubuntu budou fungovat vždy, když IDEA a kol. zaměření.

Mám kolekci zkratek specifických pro JetBrains zde ; vstup je oceněn.

    
odpověděl Raphael 22.12.2016 14:32
2

Stačí se trochu rozšířit o skvělou odpověď společnosti AzkerM:

  
  • Zakažte akci Přesunout okno, přiřazené Alt + F7      
        
    • v nastavení - > Klávesnice - > Klávesové zkratky - > Windows - > Přesunout okno
    •     
  •   
  • Změňte nebo deaktivujte akci okna Změnit velikost, přiřazenou Alt + F8 (Vyhodnotit výraz)      
        
    • v nastavení - > Klávesnice - > Klávesové zkratky - > Windows - > Okno Změna velikosti
    •     
  •   
    
odpověděl WillC 24.02.2016 12:15
1

Používám Ubuntu 16.04 a to, co se děje, je to, když jsem použil tyto klávesové zkratky (ctrl-alt-left / right), okno měnilo velikost a umístilo se doprava nebo doleva na obrazovce. Zkoušel jsem zakázat tyto klíče v: Nastavení / Klávesnice / Navigace, i když nemám povoleno pracovní prostory. To ještě nezabránilo chování, které jsem viděl.

Naštěstí jsem otevřel Compiz a narazil na plugin Window Management / Grid, který mapoval tyto klíče a umístil okna do mřížkové pozice. Tento plugin jsem deaktivoval a nyní klávesové zkratky IntelliJ fungují dobře pomocí kláves ctrl-alt-left / right.

    
odpověděl Jason White 14.06.2016 00:08
1

Jen nějaké rychlé řešení:
Pokud máte na klávesnici klíč Windows , můžete ji jednoduše přidat do celé kombinace zkratek - to by mělo fungovat. Například:

  • > T (Surround s)
  • F8 (Vyhodnoťte výraz )
odpověděl guzoff 28.11.2017 21:53
0

Ubuntu 16.04 přejděte na nastavení > Klávesnice a najděte konkrétní kombinaci, která je v rozporu s požadovaným kliknutím, a aktualizujte ji na novou.

    
odpověděl Cengkuru Michael 29.10.2017 10:22
0

Používám Xneur k přepínání nesprávného textu do jiného jazyka. Moje systémová langauge je označena jakoCtrl + Shift co blokuje Intellij klávesové zkratky jakoCtrl + Shift + F (Globální vyhledávání) aCtrl + Shift + C (Komentář). Takže levý posun je ignorován.

  • Jedním z řešení je změnit jazyk pomocíCtrl_L + Shift_L a použít Ctrl_R + Shift_R pro Intellij . Ale je to nějaký nepříjemný pocit.

  • Druhým řešením je použít Xneur (sudo ap-get install xneur) na zmačkat text v jiném jazyce. Můžete deaktivovat libovolné přepínání systému langauge a přiřadit jej klávesovým zkratkám xneur (stejnéCtrl+Shift). Xneur lze přidat do autostartovaných aplikací.

odpověděl Zon 04.09.2018 07:28