Jak mohu deaktivovat Bluetooth při spuštění systému?

279

Jak mohu deaktivovat Bluetooth při spuštění systému?

    
dané Floqqi 16.10.2011 23:02

28 odpovědí

190

18.04+ uživatelů, kteří přirozeně nemají /etc/rc.local, budete muset vytvořit jeden a spustit jej. Chcete-li věci trochu jednodušší, stačí pouze vložit následující příkaz do terminálu:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Spusťtesudoedit /etc/rc.local a přidejte toto před řádek sexit 0:

rfkill block bluetooth

Ještě byste měli umožňovat Bluetooth prostřednictvím horního appletu.

Tento by měl fungovat pro většinu systémů, ale vypadá to, že v jádře ACPI pro Thinkpads číhá několik chyb. Pokud jste na Thinkpadu, přidejte následující příkaz do/etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Nebo se podívejte na ibm-acpi - ovladač IBM ThinkPad ACPI Extras - některé zprávy naznačují, že ibm-acpi obsahuje řízení bluetooth (mimo jiné krásné věci). Ale nemám hardware, takže jsem úplně neschopný ověřit tyto požadavky. Hodně štěstí.

    
odpověděl Oli 18.08.2010 11:00
73

Našel jsem postup s čistým "řešením" zde ( archivovat odkaz pro potomstvo)

Vlastní změna/etc/bluetooth/main.conf mi stačila.

Z článku:

Vyhledejte záznam:

InitiallyPowered = true

a změňte hodnotu na:

InitiallyPowered = false

Byl to dost pro mě, i když článek popisuje některé další kroky, které mohou nebo nemusí být nutné.

Ubuntu 17.10 a Ubuntu 18.04 byla volbaInitiallyPowered nahrazenaAutoEnable

    
odpověděl Stepbaer 25.06.2012 20:00
23

Zakázání ovladače bluetooth při načítání při spuštění:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

přidat:

blacklist btusb

Povolení je později by mělo být:

sudo modprobe btusb
    
odpověděl maco 18.08.2010 18:59
16

Krok 1: Přejděte na terminál a zadejte následující příkaz pro úpravu souboru/etc/rc.local systému:

gksudo gedit /etc/rc.local

Krok 2: Přidejte následující řádek před řádekexit 0:

rfkill block bluetooth
    
odpověděl Varun 04.05.2012 22:44
12

Od systému ubuntu 16.04 systémd spravuje služby spouštění jako bluetooth ... pro zobrazení aktuálního problému stavu v terminálu

sudo systemctl status bluetooth.service 

k deaktivaci bluetooth při spuštění tohoto problému

sudo systemctl disable bluetooth.service

při dalším restartování bluetooth nebudou aktivní ... povolit vydání bluetooth

sudo systemctl enable bluetooth.service
    
odpověděl Scott Stensland 01.08.2017 17:08
7

Do terminálu zadejte následující:

sudo gedit /etc/modprobe.d/blacklist.conf

V dolní části souboru přidejte řádek:

blacklist bluetooth

Uložte soubor a restartujte - Bluetooth by měl být nyní zakázán.

    
odpověděl Nathan Osman 16.10.2011 23:25
7

Službu spuštěnou při zavádění můžete změnit pomocí BUM .

Nainstalujte jej:sudo apt-get install bum

Spustit:sudo bum

Zrušte zaškrtnutí políčka a klikněte na tlačítko Apply .

    
odpověděl desgua 05.05.2012 02:09
5

Myslím si, že nejlepším způsobem je zakázat službu, aby byla spuštěna na prvním místě. Existuje obecná metoda pro zakázání služeb, která funguje dokonale:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

To funguje pro Ubuntu 13.10 a pravděpodobně i pro dřívější verze.

    
odpověděl Felipe 18.01.2014 10:49
5

Přidám

"/etc/init.d/bluetooth stop"

do

"/etc/rc.local" 

před příkazem "exit 0" pro spuštění s vypnutým rozhraním Bluetooth.

    
odpověděl Saeed Zarinfam 23.08.2012 15:00
5

1. blok bluetooth v rc.local

Přidejte tento řádek na konec souboru/etc/rc.local přímo před čárouexit 0:

rfkill block bluetooth

Toto provede trik, ale pouze ve starších verzích Ubuntu pomocí upstart .

2. znovu zapněte rc.local na systemd

Ubuntu 15.10 se systémem systemd jako správce při spuštění není soubor/etc/rc.local ve výchozím nastavení ve výchozím nastavení používán, takže volání na terminálu:

sudo systemctl edit --full rc-local

Kterou se otevře editor. Na konci souboru jsem přidal:

[Install]
WantedBy=multi-user.target

Tyto změny jsou aktivovány

sudo systemctl reenable rc-local

Nyní se používá soubor/etc/rc.local, jak ho znáte.

3. vypnout blueman-applet při startu

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Nyní je blueman-applet viditelný a můžete ho vypnout ze spouštěcích programů

4. Restartujte, abyste viděli efekt

    
odpověděl rubo77 10.11.2015 13:29
4

Můžete upravit nastaveníupdate-rc.d. Použil jsem něco podobného:

sudo update-rc.d bluetooth remove

V Debianu Wheezy. Podívejte se naman update-rc.d pro více informací o tom, jak ji používat.

    
odpověděl Keith Smiley 13.02.2013 16:50
2

Možná ho můžete vypnout v aplikacích pro spuštění. Tyto aplikace jsou však ve výchozím nastavení skryté. Odkrytí skrytých spouštěcích aplikací v 12.04: Otevřete terminál a spusťte tyto dva příkazy:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Nyní můžete odznačit bluetooth. (Neodstraňujte!)

    
odpověděl schiemanski 05.05.2012 10:50
2

Ne. Není to vždy v seznamu spouštěcích aplikací. Myslím, že nejlepším řešením je přidat příkaz rfkill v skriptu rc.local nebo nastavit parametrInitiallyPowered v/etc/bluetooth/main.conf.

    
odpověděl Robert 05.05.2012 02:06
2

1) Nainstalujte balíček smbios-utils a přidejte jej do Startup Applications pomocí:

sudo smbios-wireless-ctl --bt 0

2) Typ terminálu:

sudo visudo

a přidejte do konce otevřeného souboru/etc/sudoers řádek:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) Chcete-li přepnout bluetooth během relace, spusťte v terminálu:

sudo smbios-wireless-ctl --bt 1

To funguje pro mě na mém Dell D630 s Ubuntu 13.10

    
odpověděl victor 15.03.2014 16:58
2

Na Ubuntu 16.04 jsem jednoduše zakázal službu při spuštění pomocí systému.

Chcete-li to provést, otevřete okno terminálu a zadejte následující:

sudo systemctl disable bluetooth

Můžete buď restartovat, protože od okamžiku, kdy bluetooth bude vypnut po spuštění nebo pokud nechcete rebootovat a chcete okamžitě zastavit bluetooth, můžete zadat:

sudo service bluetooth stop

    
odpověděl Ken 22.08.2017 05:57
2

Můžeme vypnout bluetooth auto start takto:

sudo gedit /etc/bluetooth/main.conf

(gedit je můj editor fav, můžete jej nahraditxed nebo cokoliv, co je nainstalováno ve vašem systému.)

Na spodku tohoto souboru je tento řádek:

#AutoEnable=false

Zrušte komentář, například:

AutoEnable=false
    
odpověděl Shayan 20.02.2018 15:47
1

Používám Sputnikové jádro , které to opravilo na mém Dell Inspiron 14R N4110.

    
odpověděl Alex Wiedermann 25.09.2012 01:53
1

Myslím, že byste měli upravit

/etc/default/bluetooth

a nastavte

BLUETOOTH_ENABLED=0

zakážete službu bluetooth při zavádění

    
odpověděl Fabio 06.03.2014 21:17
1

Pro ty z vás, kde vkládání řádkurfkill block bluetooth (nebo jiné) v/etc/rc.local nefunguje, zkuste zahrnout stejný řádek do konce~/.bashrc

V mém nastavení (Ubuntu 14.04, Thinkpad W540), žádná možnost nefungovala vložením do/etc/rc.local, ale první pracoval v bashrc. Všimněte si, že to bude fungovat pouze pro aktuálního uživatele, nikoliv globálně pro všechny uživatele.

    
odpověděl Sam 19.10.2014 14:10
1

V Ubuntu Studio 16.04 můžete vypnout funkci Bluetooth Applet při spuštění:

  

Session a Startup > Aplikace Autostart > Applet Bluetooth

Zde můžete kliknout na pole, abyste jej deaktivovali.

    
odpověděl ateymuri 26.08.2016 20:05
0

Přidám

"/etc/init.d/bluetooth stop"

do

"/etc/rc.local" 

před příkazem "exit 0" pro spuštění s vypnutým rozhraním Bluetooth.

    
odpověděl Saeed Zarinfam 23.08.2012 15:05
0

Řešení pro můj notebook

"Konfigurace systému BIOS - USB - EHCI2: Zakázáno"

EHCI1 je určen pro usb porty (vlastně Můj notebook má 2 porty 2.0 usb)

    
odpověděl MSP 27.03.2014 19:46
0

Upravit/etc/default/grub:

sudo nano /etc/default/grub

a změňte následující řádek:

GRUB_CMDLINE_LINUX=""

namísto toho:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Aktualizujte grub a restartujte:

sudo update-grub
    
odpověděl mchid 21.09.2015 07:58
0

Toto by mělo zabránit spuštění systému bluetooth na systémech založených na Debianu:

sudo chkconfig bluetooth off

nebo na systémech založených na RedHat

systemctl disable bluetooth.service
    
odpověděl Stanislav 16.10.2017 22:18
0

Pokud používáte applet Bluetooth v horním panelu (blueman-applet), má vlastní nastavení, které automaticky zapne funkci Bluetooth, i když jste jej deaktivovali na jiných místech (např. / etc / bluetooth / main .conf nebo / etc / default / tlp).

Zabránit zapnutí technologie Bluetooth při spuštění pomocí příkazového řádku:

gsettings set org.blueman.plugins.powermanager auto-power-on false

Nebo pomocí GUI:

  1. Klikněte na applet Bluetooth > Pluginy > PowerManager > Konfigurace
  2. Odškrtněte Automatické zapnutí

Při příštím restartování bude applet Bluetooth stále viditelný, ale Bluetooth bude vypnuto. Zapnutí:

Klikněte na applet Bluetooth > Zapnout Bluetooth zapnuto

    
odpověděl bmaupin 27.07.2018 19:12
-1

Musel jsem použít metodu brute-force k zastavení bluetoothd od automatického spouštění při startu. Přemenoval jsem spustitelný soubor, takže ho nebyl nalezen.

    
odpověděl bluesdiva2001 06.07.2012 03:02
-1

Můžete také použít tuto grafickou aplikaci, která také tento správce bluetooth

    
odpověděl deFreitas 27.12.2014 14:26
-3

Musíte ji deaktivovat ze seznamu Spustit aplikace v Nastavení systému.

Klikněte na ozubení v pravé horní části panelu nabídek a vyberte položku Nastavení systému.

Klikněte na položku Spustit aplikace a pak se posuňte dolů, dokud nenajdete nastavení Bluetooth, zaškrtněte políčko a vy všichni jste hotovi.

    
odpověděl Mark Rooney 16.10.2011 23:13