Jak nainstalovat Adobe Flash Player?

101

Měl jsem značné problémy s sledováním flash videa v 64bitovém Ubuntu. Ví někdo o dobrém způsobu, jak spustit blesk na platformě?

    
dané Steven Oxley 28.07.2010 21:27

20 odpovědí

81

Pro 11.04 a dřívější:

Instalujete jej z softwarového centra Ubuntu?

  1. Přejděte do aplikace Software > Centrum softwaru Ubuntu.
  2. Klikněte na Canonical Partners
  3. Klepněte na plugin Adobe Flash 11 a klepněte na tlačítko install.

Poznámka: Toto je metoda, kterou používám k instalaci 64bitové verze Ubuntu, a dosud se mi to nepodařilo.

    
odpověděl Nathan Osman 28.07.2010 21:31
68

Pro 11.10 a později

Spusťte softwarové centrum z spouštěče a vyhledejte flash

Dva položky budou nalezeny. První je obal kolem 32bitové verze Flash od společnosti Adobe. Druhá je 64bitová verze flash.

Vyberte druhou položku blesku - pokud je zobrazen následující snímek, již jste dříve nepoužívali repozitář Canonical Partner.

Klikněte na Další informace

... a kliknutím na tlačítko Použití tohoto zdroje povolíte repozitář Canonical Partner

Podívejte se na konec této odpovědi na zprávu o chybách

Klepněte na tlačítko Nainstalovat

Klikněte na tlačítko Instalovat a po zobrazení výzvy zadejte své heslo. Poznámka - musíte mít oprávnění k instalaci softwaru.

Instalace bude pokračovat:

Po dokončení - spusťte aplikaci Firefox a přejděte na video ve formátu Flash. Klikněte pravým tlačítkem a potvrďte, že byla nainstalována nejnovější verze aplikace Flash.

Poznámka - obrázky mohou být změněny - 64bitová verze byla nedávno zabalena v posledním týdnu před vydáním Oneiric - v současnosti existuje jeden problém:

  1. Odkaz

Mezitím použijte první plugin "Multiverse" 32bit na výše uvedených obrázcích nebo použijteadobe-flashplugin

sudo apt-get install adobe-flashplugin
    
odpověděl fossfreedom 10.10.2011 00:52
31

Takto nainstalujte Adobe Flash Plugin pro Firefox:

  1. Přejděte na stránku tuto a vyberte jinou možnost .tar.gz pro jiný systém Linux. Stáhněte soubor.
  2. Rozbalte plugin tar.gz a zkopírujte soubory na příslušné místo.
  3. Uložte plugin tar.gz místně a uvědomte si umístění, do kterého byl soubor uložen.
  4. Spusťte terminál a změňte adresáře na místo, kam byl soubor uložen.
  5. Rozbalte soubor tar.gz. Po rozbalení uvidíte následující:

    • libflashplayer.so
    • / usr
  6. Určete umístění adresáře pluginy prohlížeče na základě distribuce Linuxu a verze Firefoxu (obvykle je/usr/lib/mozilla/plugins/). U cesty ubuntu 14.04 je:/usr/lib/firefox/browser/plugins

  7. Kopírujtelibflashplayer.so do příslušného adresáře pluginů prohlížeče. Na výzvu typ:

    sudo cp libflashplayer.so <BrowserPluginsLocation>
    
  8. Zkopírujte soubory konfigurace Místního nastavení aplikace Flash Player do adresáře / usr. Na výzvu typ:

    sudo cp -r usr/* /usr
    
  9. Nyní restartujte prohlížeč.

odpověděl ignite 04.09.2012 18:36
21

Protože jste uvedli, že se jedná o poprvé, kdy jste někdy používali ubuntu. Navrhoval bych, že nainstalujete balíček ubuntu-restricted-extras, obsahuje spoustu užitečných věcí, jako je Adobe flash a kodeky a fonty MS atd.

můžete to udělat mnoha způsoby.

centrum softwaru: Klikněte na tento odkaz:

nebo v terminálu: typsudo apt-get install ubuntu-restricted-extras

synaptic: vyhledejte balíček ubuntu-restricted-extras, klepněte pravým tlačítkem myši na balíček a vyberte instalaci a vyberte značku. po kliknutí na tlačítko použít a vše se nainstaluje.

    
odpověděl Terry 02.04.2011 16:02
13

Existuje jednoduché řešení tohoto problému.

Otevřete Firefox a přejděte na stránku Youtube . Klikněte na libovolné video. Rozhodně to nebude fungovat, protože nemáte nainstalován flash player. Firefox vás ale povede nainstall missing plug-in v horní části stránky. Jednoduše klikněte na něj a postupujte podle pokynů. Potom se vaše video začne přehrávat. Ujistěte se, že máte nainstalovaný nejnovější prohlížeč Firefox .

Nebo zkuste to v terminálu

sudo apt-get install flashplugin-installer
    
odpověděl Kaktarua 04.09.2012 18:38
5

Získejte rozšíření Flash-Aid pro Firefox. Bude se starat o stažení a instalaci příslušné verze architektury systému a také odstranění konfliktních pluginů. Pokud používáte 64bit, dovoluje také nainstalovat 64bitovou verzi náhledu, která poskytuje lepší výsledky než 32bit s nspluginwrapper.

BTW, pokud nemůžete kopírovat nic do složky ~ / .mozilla / plugins, měli byste zkontrolovat vlastnictví složky ~ / .mozilla. Mělo by to umožnit zkopírovat cokoliv tam. Pokud samozřejmě nehovoříte o systémové složce mimo domovský adresář, který vyžaduje oprávnění root.

    
odpověděl lovinglinux 02.12.2010 13:40
4

Záleží na tom, který prohlížeč používáte. Google Chrome (nikoli Chromium) má přehrávač Flash ve výchozím nastavení.

Přejděte na adresu www.google.com/chrome a klikněte na stažení Chrome. Vyberte 64bitový .deb (někdo čte tento pomocí 32bitových strojů by měl vybrat 32bitový .deb)

Po klepnutí na soubor .deb po jeho stažení se otevře v softwarovém centru. Nyní klikněte na instalaci a po dokončení najdete prohlížeč v aplikaci Aplikace - > Internet.

    
odpověděl Mozart321 02.04.2011 22:00
2

Použijte softwarové centrum Ubuntu (v nabídce Aplikace). Do pole pro zadání textu (vyhledávacího pole) můžete vyhledávat "flash" a výsledky doplní jeden plugin Adobe Flash (poznamenejte si logo Adobe). Zvolte to a postupujte podle pokynů pro použití zdroje.

    
odpověděl Daniel T Chen 01.12.2010 20:14
2

Zkontrolujte, který adresář "plugin" se používá. Musel jsem strávit dobrou hodinu, jen když jsem si prošel všechny adresáře pluginů, dokud jsem zjistil, které z nich firefox skutečně čte, a pak je všechno vybralo, aby ukázalo na obyčejný.

Konec dne, kdy byste ho mohli vynechat na nesprávném místě.

Také spusťte firefox z příkazového řádku, mohou se zobrazit chyby. Příkladem je přehrávač flash x86 v prohlížeči x64 (nikoliv os) a naopak. Z příkazového řádku (ln -s) byste měli vidět řádky protokolu inicializace pluginů. (možná zkuste tohle první: P)

Také cokoliv v%> firefox je vlastněno kořenem, takže byste museli/usr/lib/... kdesudo cp libflashplayer.so /usr/lib/firefox/plugin odkazuje na umístění adresáře pluginů firefox.

    
odpověděl Dmitriy Likhten 01.12.2010 20:51
2

Určitá oprava pro 64bitový blesk na 11.10

Opravil jsem 64 bitový blesk na mých systémech 11.10 bez obalů. Pokud budete postupovat podle výše uvedených řešení, budete stále mít 32bitovou verzi a obaly.

Poznámka: Většina z toho může být provedena také v terminálu, v takovém případě nemusíte instalovat Synaptic. Dále by mohlo stačit, že stačí provést kroky 5, 6 a 8, ale ještě jsem to netestoval.

  1. Nainstalujte Synaptic (softwarové centrum nezobrazuje požadovaný balík, nikoliv v hlavních položkách, nikoliv v technických položkách a ani po jeho instalaci)
  2. Spusťte službu Synaptic a vyhledejte funkci "flash"
  3. Seřadit podle nainstalovaného stavu
  4. Odstraňte všechny balíčky související s bleskem (například flashplugin-downloader: i386, flashplugin-installer, ndiswrapper-common apod.). Pokud není uvedeno nic, pravděpodobně nemáte vůbec nainstalovaný Flash. V takovém případě se přesuňte na další krok.
  5. Povolte repozitář kanonického partnera (viz výše uvedené příspěvky, jak postupovat)
  6. Aktualizujte seznam balíčků (nezaměřujte se na to, že to Software Center dělá pro vás, někdy to neznamená) klepnutím na tlačítko Znovu načíst
  7. Vyhledejte znovu 'flash'
  8. Nainstalujte balíček "adobe-flashplugin". Pokud není v seznamu, došlo k chybě při aktualizaci seznamů balíků. Pokuste se ukončit a restartovat službu Synapic a poté kliknout na tlačítko "Znovu načíst".

Jeden další balíček, "adobe-flash-properties-gtk", bude nainstalován automaticky. Nic víc.

Nyní budete mít plný 64 bitový Flash bez obalů a jiných odpadků v prohlížeči Firefox i Chromium. Je však nutné restartovat prohlížeč (y). Pokud stále nefunguje, zkuste restartovat (možná někde existuje falešná reference na staré pluginy).

    
odpověděl iGadget 12.11.2011 13:18
2

sudo apt-get remove --purge adobe-flashplugin flashplugin* nspluginwrapper
sudo apt-get install --reinstall adobe-flashplugin

Ref: Odkaz

    
odpověděl Coc 20.11.2011 11:21
2

Zde je to, co musíte udělat: ve výchozím nastavení je Ubuntu dodáván pouze s povoleným softwarem s otevřeným zdrojovým kódem (myslím, že to tak je, stejně).

Způsob, jakým povolujete další věci (například Flash, Java a podporu pro nahrávání nebo přehrávání MP3, které nejsou otevřeným zdrojem) je přejít do softwarového centra, jít do menu (bohužel nejsem v současné době na Ubuntu a nemůže vám říct, která nabídka) a vyhledávat zdroje softwaru.

Klepněte na něj a budete přeneseni do okna, které informuje Ubuntu, co je pro vás možné nainstalovat. Před vámi by měl být seznam pěti různých "vesmírů". Co je třeba udělat, je povolit dvě, které nejsou aktuálně povoleny.

Potom by se měl zeptat, zda chcete znovu načíst úložiště, ale pokud se tak nestane, dostanete se do příkazového řádku a zadejte

sudo apt-get update

a nechte to dokončit. Pak byste měli najít blesk v softwarovém centru nebo v příkazovém řádku. Mohli byste alternativně nainstalovat balíček ubuntu-restricted-extras, který vám poskytne všechny tři věci, které jsem uvedl výše.

Hodně štěstí!

    
odpověděl Noah 04.09.2012 18:14
2

Prošel jsem co nejvíce možných návrhů, které jsem našel ve snaze dostat blesk do práce v prohlížeči Chrome na mém 13bitovém 64bitovém instalačním programu. Nic nefungovalo. Nakonec jsem narazil na odpověď Pepper Flash.

Existují úplné a dobře napsané pokyny na (odkaz je přímý)

ubuntuhandbook.org

Upřesňují přidávání úložiště, aktualizaci apt, instalaci Pepperu a úpravu konfigurace chrome. Věc, kterou jsem udělala jinak než jejich pokyny, byla změna adresáře / etc / chromium-browser a vydání příkazu

sudo gedit default

, což mi umožnilo přidat k souboru i komentář k nezbytným .sh info, takže poslední řádky mého modifikovaného výchozího souboru byly:

# enable Pepper Flash Player Plugin
. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Doufejme, že toto řešení bude nějakou dobu fungovat.

    
odpověděl zenpistolero 03.05.2014 01:58
2

Videoklipy ve formátu Flash nebudou hrát na nové instalaci systému Ubuntu 14.04, a to i sadobe-flashplugin z repozitáře partnerů - černá obrazovka na youtube (s výjimkou nastavení pro použití HTML5 ), dailymotion atd. Instalace freshplayerplugin (zřejmě obal pro flashový přehrávač Chrome) vyřešil problém:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin
    
odpověděl Skippy le Grand Gourou 22.08.2015 09:33
1

V případě, že

sudo apt-get install flashplugin-nonfree

nefunguje (jako v mém případě a nevím proč ...), můžete zkusit operaci jako svůj prohlížeč. Je to jediné, co pro mě pracuje.

PS: Nechci inzerovat Opera do prohlížeče, je to jen to jediné řešení, které nějak pracovalo pro mě.

    
odpověděl Remi Meier 14.08.2010 15:19
1

Právě jsem našel řešení pro ty, kteří pracují ve Firefoxu, ale ne na Chromu. Je založen na tom, že každý prohlížeč má vlastní adresář pluginů:

  • / usr / lib / firefox-addony / pluginy (pro Firefox)
  • / usr / lib / chromium-browser / pluginy (pro Chromium)

Takže jediná věc, kterou musíte udělat, je sjednotit je, aka tak, že vytvoříte jeden odkaz na druhý. Pravděpodobně jsou všechny pluginy v adresáři modulů Firefox, ale nestojí za to, že:

ls -l /usr/lib/{mozilla,chromium-browser}/plugins

Pokud je Firefox ten, kde jsou všechny pluginy, udělejte další. Pokud tomu tak není, udělejte opak:

sudo rmdir /usr/lib/chromium-browser/plugins
sudo ln -s /usr/lib/mozilla/plugins /usr/lib/chromium-browser/

Konečně restartujte Chromium, takže změny se projeví.

Pravděpodobně by nebyl špatný nápad sestavit zprávu o chybě na správce balíků Chromium / Firefox, abyste upozornili na chybu a jednoduché řešení.

    
odpověděl emi 16.08.2012 19:19
1

No já to posílám tady, v naději, že někomu pomohu. Uvádím, co se děje a jak jsem to vyřešil.

NASTAVENÍ:
    Spuštěna 12.04 z instalace WUBI.

PROBLÉM:
    Když jsem prohledal v softwarovém centru Ubuntu klíčové slovoflash, žádná z zde zveřejněných možností se objevila kromě ONE proflash plugin pro Mozilla. Při pokusu o instalaci jsem dostal chybu závislosti.

Pokusili jste se jej nainstalovat pomocí Ubuntu Restricted Extra z softwarového centra Ubuntu, avšak část pluginu této instalace nefungovala kvůli chybě závislosti.

Zachoval vyhledávání a našel tento příkaz pro instalaci pluginu

sudo apt-get install flashplugin-nonfree

a spustil jej z terminálu.

Stejná chyba závislosti s tímto výstupem:

Reading package lists... Done Building dependency tree        
Reading state information... Done Note, selecting 'flashplugin-installer' instead of 'flashplugin-nonfree' 
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. 
The following information may help to resolve the situation:
The following packages have unmet dependencies:  
 flashplugin-installer : 
 Depends: libnspr4-0d but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Řešení:

Běžel jsem

sudo apt-get install -f 

a potom

sudo apt-get update 

, které jsem našel z nějakého jiného příspěvku, který se snažil vyřešit závislosti.

Pak jsem běžel

sudo apt-get install flashplugin-nonfree

a plugin Flash nyní funguje na Chromiu a Firefoxu.

    
odpověděl Joel 02.10.2012 17:55
1

Záleží na tom, jak instalujete. je to přes soubor tar.gz nebo rpm nebo nějakou jinou metodu. Existuje spousta způsobů, jak dostat blesk.

Download link: https://get.adobe.com/flashplayer/

Installation instructions
-------------------------

Installing using the plugin tar.gz:
    o Unpack the plugin tar.gz and copy the files to the appropriate location.  
    o Save the plugin tar.gz locally and note the location the file was saved to.
    o Launch terminal and change directories to the location the file was saved to.
    o Unpack the tar.gz file.  Once unpacked you will see the following:
        + libflashplayer.so
        + /usr
    o Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version
    o Copy libflashplayer.so to the appropriate browser plugins directory.  At the prompt type:
        + cp libflashlayer.so <BrowserPluginsLocation>
    o Copy the Flash Player Local Settings configurations files to the /usr directory.  At the prompt type:
        + sudo cp -r usr/* /usr

Installing the plugin using RPM:
   o As root, enter in terminal:
          + # rpm -Uvh <rpm_package_file>
          + Click Enter key and follow prompts

Installing the standalone player:
   o Unpack the tar.gz file
   o To execute the standalone player,
          + Double-click, or 
          + Enter in terminal: ./flashplayer

Bonus:

Uninstallation instructions
---------------------------

Manual uninstallation (for users who installed the plugin via Install script):
   o Delete libflashplayer.so binary and flashplayer.xpt file in 
   directory /home/<user>/.mozilla/plugins/

RPM uninstallation:
   o As root, enter in terminal:
          + # rpm -e flash-plugin
          + Click Enter key and follow prompts
    
odpověděl Revanth Kumar 02.05.2015 03:59
0

Zkontroloval jsem mnoho otázek o tomto tématu za poslední týden. Nakonec jsem našel odkaz s řešením, které funguje:

Odkaz

V podstatě je odpovědí, že se zdá být odstraněna ze všech zdrojů softwaru a stahovat starou verzi a ručně ji nainstalovat.

    
odpověděl palbeda 12.04.2017 16:33
0

  

Linux již ve svém obchodě již nepodporuje Adobe Flash Player. Proto je nutné to provést ručně.

  

Ověřuje se pouze v prohlížeči Firefox, pokud máte Chrome / Chromium, který jej nemusíte instalovat.

Existuje postup ruční instalace přehrávače Adobe Flash Player na Ubuntu, postupujte takto: -

  1. Otevřete tento odkaz . Automaticky vám navrhne verzi podle prostředí vašeho počítače.

  2. Zvolte možnost.tar.gz for Linux, jak je uvedeno níže.

  3. Nyní klikněte na tlačítko pro stahování (pro snadný přístup vyberte cestu pro stahování Stahování )

  4. Nyní extrahujte souborRight clicking do složky a vyberte možnostExtract Here.

  5. Otevřete Terminál CTRL+ALT+T a zkopírujte níže příkaz po jednom

    5.1. cd ../

    5.2. cd your-pc-name (např., paper96)

    5.3. cd Downloads (toto je složka, ve které jste soubor stáhli v Možnost 3 ).

    5.4. cd flash_player_npapi_linux.x86_64 (Název souboru se může lišit pouze zkopírovat název souboru a vložit jej do terminálu)

    5.5. sudo mv libflashplayer.so \/usr/lib/firefox-addons/plugins stiskněte enter a to je.

  6. Nyní zavřete prohlížeč (Firefox) a Terminál.

  7. Restartujte Firefox a nyní máte ve svém prohlížeči Flash Player. Navštivte tento odkaz a ověřte.

odpověděl Pankaj Gautam 17.07.2017 09:52