Jak zakázat návštěvu hosta?

182

Jak lze zakázat relaci hosta v Ubuntu 11.10 nebo novější? Nechci, aby lidé mohli používat počítač bez použití hesla k přihlášení!

    
dané Jeremy Bicha 22.09.2011 17:45

12 odpovědí

118

Aktualizováno: 2016-Aug

U Ubuntu 16.04 LTS (15.10 nebo novější)

Upraveno z: LightDM Ubuntu Wiki - konfigurace

  • Systémové konfigurační soubory v/usr/share/lightdm/ jsou neurčené , aby byly uživatelsky upravitelné. Místo toho by uživatelé měli používat:/etc/lightdm/
  • Novější verze softwaru LightDM (Ubuntu 15.10 nebo novější) používají[Seat:*] namísto[SeatDefaults]

Spusťte toto (jednou) na terminálu:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Chcete-li vrátit zpět (obnovit možnost Host), odebrat vytvořený soubor :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Pro Ubuntu 14.04 LTS (do 15.04)

Upraveno z: Fóra Ubuntu - umístění konfiguračních souborů lightdm v 14.04

Spusťte toto (jednou) na terminálu:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

Již nebudete mít možnost "Host" jako přihlášení, při dalším přihlášení.

Chcete-li vrátit zpět (obnovit možnost Host), odebrat vytvořený soubor :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Pro Ubuntu 12.04 LTS (do 13.10)

Nejjednodušší metoda.

Spusťte toto (jednou) na terminálu:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

Již nebudete mít možnost "Host" jako přihlášení, při dalším přihlášení.

  • Toto jednoduše přiložíallow-guest=false na/etc/lightdm/lightdm.conf.

  • Měl by fungovat od 11.10 dále (protože používají LightDM ).

Chcete-li vrátit zpět (obnovit možnost Host):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
odpověděl david6 28.07.2012 01:38
115

  

Použijte tuto metodu pouze v případě, že používáte Ubuntu Desktop. Pokud používáte jinou příchuť jako Xubuntu nebo Lubuntu přejděte na tuto odpověď místo.

Pokud používáte výchozí LightDM, upravte/etc/lightdm/lightdm.conf tak, aby to vypadalo takto:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Pokud používáte GDM (což bylo výchozí v předchozích verzích Ubuntu), odinstalujte session-session guest .

Ubuntu 13.10 na 14.10 se soubor přesune na/etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Ubuntu 14.10 nebo vyšší se soubor přesunul /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

    
odpověděl Jeremy Bicha 22.09.2011 17:48
24

Zadejte do terminálu

gksu gedit /etc/lightdm/lightdm.conf

Uvidíte následující:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Přidejte do konceallow-guest=false, aby konečný výsledek vypadal takto:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Uložte dokument a ukončete textový editor.

Zpět v terminálu restartujte správce zobrazení. (Toto ukončí grafickou přihlašovací relaci a okamžitě ukončí všechny běžící programy, takže ujistěte se, že vaše práce - jako všechny otevřené dokumenty - je uložena jako první!)

sudo restart lightdm

Po skončení grafické relace přihlášení se vrátíte na přihlašovací obrazovku, kde si všimnete, že účty hostů jsou zakázány.

To je - účet hosta již není použitelný.

    
odpověděl sarveshlad 25.10.2011 03:08
17

Můžete to udělat pomocí Ubuntu Tweak .

Chcete-li jej nainstalovat, použijte tyto příkazy:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Po instalaci přejděte na Vylepšení → Nastavení přihlášení a vypněte účet Guest.

    
odpověděl Eliran Malka 21.10.2012 19:54
11

Stačí spustit

gksudo gedit /etc/lightdm/lightdm.conf

Přidejte následující řádek

allow-guest=false

Poté (toto vás okamžitě odhlásí, ukončíte všechny programy spuštěné v grafické relaci, proto nejprve uložíte svou práci):

sudo restart lightdm
    
odpověděl LnxSlck 27.07.2012 18:42
4

Jak tuto možnost vypnout v budoucnu

Právě jsem nastoupil do stejného problému v nové instalaci s důvěrou / 14.04. Také kvůli překvapení jsem nenašellightdm.conf.d složky uvnitř/etc/lightdm/ justusers.conf.

Vyšetřování

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, jste tam. Co je tam?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Dobře, co je tam?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Závěr

Najdeme spoustu konfiguračních souborů podobných formátu INI , které následují po schématu pojmenování50-${some-descriptive-name}.conf a konfiguraci klíčů pro část[SeatDefaults].

Nebudeme upravovat žádný z těchto souborů , jelikož tyto soubory mají být spravovány správcem balíčků, ale nyní bychom měli přidat a spravovat naše Vlastní konfigurační bity do/etc.

Řešení

Vzhledem k výše uvedenému je to lightdm správce zobrazení a konfigurační soubory vypadají jako výše. Následující řešení by mělo fungovat:

  1. Vytvořte chybějící adresáře:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Přidáním vlastního konfiguračního souboru:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    a vložte následující řádky:

    [SeatDefaults]
    allow-guest=false
    

    Pak uložte ( Ctrl + O ) a zavřete ( Ctrl

  3. Nyní se odhlaste a přepněte na virtuální terminál ( Ctrl + Alt + F1

    $ sudo service lightdm restart
    

    Možnost návštěvy hosta by nyní měla být pryč. Pokud něco nefunguje správně, víte, kde je uložena výchozí konfigurace a že jste ji nezměnili.

Další čtení

odpověděl LiveWireBT 16.03.2014 03:32
3

Pro Ubuntu 13.10 přidejte

allow-guest=false

do souboru/etc/lightdm/lightdm.conf.d/10-ubuntu.conf.

    
odpověděl uahummer 20.10.2013 15:27
3

13.04 a novější

  1. Proveďte tento příkaz v terminálu

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Restartujte počítač nebo restartujtelightdm pomocí následujícího příkazu (Tím se okamžitě odhlásíte, uložíte data)

    sudo restart lightdm
    

Zdá se, že to funguje v 13:10 (nelze otestovat sám, ale tam je poznámka zde ).

Používám 13.04 a všechno to přidáváallow-guest=false to/etc/lightdm/lightdm.conf, ale může to být jinak v 13.10.

Původně podle david6 zde: Odkaz

    
odpověděl kiri 21.10.2013 09:33
2

Nainstalujte ubuntu-tweak, přejděte na kartu vylepšení, vypněte tlačítko hosta a restartujte. A je to!

Terminál je jednodušší, ale v případě, že je zapotřebí zapnout účet hosta, pak byste museli navštívit tuto stránku znovu a podívat se na instrukce (nebo spíše zpět). To je výhoda věci GUI ... ten si ji snadno pamatuje.

    
odpověděl tadatma 27.09.2012 19:33
2

Změňteallow-guest=true na'false' v/etc/lightdm/lightdm.conf

Můžete tedy restartovat nebo restartovat službu v terminálu:

sudo restart lightdm

Za předpokladu, že používátelightdm, což je standardní v 11.10.

    
odpověděl filescraps 21.10.2011 12:42
0

Jsem ve stejném případě, soubor/etc/lightdm/lightdm.conf neexistuje v UBUNTU 13.10.

Snažím se vytvořit soubor/etc/lightdm/lightdm.conf s tímto řádkemallow-guest=false a CRASH se systém nespustí správně, pouze režim konzoly ...

Snažím se upravit soubor/etc/lightdm/lightdm.conf.d/10-ubuntu.conf a pracovat správně.

Upravte soubor

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

A zadejte řádky, které potřebujete

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

A poslední, restartujte systém

sudo reboot

Myslím, že to funguje dobře, pokud restartujete pouze ligthgdm

sudo service lightdm restart
    
odpověděl Foncu 23.10.2013 16:05
0

Otevřete terminál

gksudo gedit /etc/lightdm/lightdm.conf

Přidejte následující řádek

allow-guest=false

Uložte a ukončete soubor.

    
odpověděl scouser73 21.10.2013 09:29