Wifi nefunguje po pozastavení po aktualizaci 16.04

134

Tato konkrétní verze "nefunguje po pozastavení" přišla po upgradu na 16.04. Zdá se, že upgrade zahrnuje applet Wicd (přidán do panelu nástrojů Metacity Classic Gnome vedle pravidelné ikony sítě), ale nezdá se, že funguje po pozastavení. Asudo service network-manager restart tento problém duplikuje. Trvá to úplné restartování, aby Wifi opět chodila. Nějaké nápady proč?

    
dané 147pm 23.04.2016 13:42

10 odpovědí

161

16.04 běží na systemd. Zkuste následující:

sudo systemctl restart network-manager.service

Pokud to funguje, můžete vytvořit skript, který ho automatizuje.

Otevřete terminál a zadejte následující:

sudo nano /etc/systemd/system/wifi-resume.service Nyní vložte skript tam s pravým kliknutím. Ukončete klávesy CTRL + X a stisknutím klávesy Y uložte. Nyní ji aktivujte:sudo systemctl enable wifi-resume.service

Skript:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Doufám, že to pomůže. Pracuje na mém notebooku.

    
odpověděl Joakim Koed 23.04.2016 15:17
8

@ 147pm Získali jste někdy tuto práci?

Zjistil jsem, že mám podobný problém, i když jsem na Kubuntu 16.10 (založený na KDE, ne Gnome) a s notebookem HP ProBook. A na rozdíl od sebe, to nebyla můj Wifi, který zemřel po pozastavení / probuzení, ale můj ethernetový port. Stále se zajímalo, jestli jsou příbuzní.

Rovněž vidím, že v KDE nemáte problém. Ale chtěl bych zajímat, jestli řešení uvedené níže pomáhá v Gnome, protože řešení není založeno na správce oken, prostředí desktopu nebo appletech.

Nejprve pouze potvrďte restartování služby správce sítě ..

$ sudo systemctl restart network-manager.service

nepracoval pro mě.

Nicméně jsem našel odpověď, která fungovala díky buzhidao otázkám a informacím v nemůže se připojit k internetu po pozastavení a komentář GAD3R tam.

Použitím svých informací jsem zjistil, že nejdříve zkoumám, který ethernetový hardware a ovladač / modul, který jsem spustil, a poté jsem odstranil a znovu nainstaloval tento modul, pro mě pracoval (i když to nebylo pro buzhidao):

Wifi:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

Druhá z nich (ethernet) byla to, co jsem použil, a našel jsem:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

Znovu jsem nainstaloval ovladač r8169:

$ sudo rmmod r8169 && sudo modprobe r8169

a voila! To fungovalo. Můj ethernetový port / připojení se vrátil naživu (po pozastavení / probuzení), aniž byste museli restartovat.

(Neměl jsem také zařízení Realtek wifi, ale Qualcomm Atheros (mod: ath9k), který snad vysvětluje, proč mi wifi pokračovala po probuzení z pozastavení práce)

Jak vidíte z mého komentáře k tomuto dalšímu příspěvku, napadlo mě, jestli je problém společným prvkem mezi Buzhidao a mnou: zařízení Realtek Semiconductor. I když používají různé moduly, mohou sdílet nějaký společný kód? Nebo dokonce s novějším jaderným kódem zacházíte jinak?

Máte sami zařízení Wi-Fi na bázi Realtek? (pomocí lspci výše)? Máte nějaké štěstí, když znovu nainstalujete modul (rmmod / modprobe výše)?

Každopádně, jen zastřelil ve tmě. Pokud jste pro sebe našli konečnou odpověď, dejte nám prosím vědět! Thx.

    
odpověděl androclus 16.03.2017 23:40
6

Chcete-li automaticky obnovit program NetworkManager po obnovení v prostředí bez přístupusudo, vytvořte skript v/etc/pm/sleep.d (libovolný název), nastavte spustitelný bit pomocíchmod +x a vložte následující obsah:

case "" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Pro mě pracoval řádekservice, alesystemctl může pracovat lépe pro vás.

Zdroj: Odkaz .

    
odpověděl krlmlr 05.11.2016 08:50
2

Pro mě to vypadá náhodně, ale někdy se wifi jen odpojí, když jsem připojen, nebo neukáže sítě, pokud nejsem. Někdy uvádění notebooku do režimu spánku se zdá spouštěním, ale ne vždy.

Některá kombinace těchto operací obvykle začíná znovu bez restartu:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • sudo service network-manager stop; sleep 5; sudo service network-manager start
    • Jednoduché volánírestart tady zde nikdy nefunguje. Zdá se, že se to pokusí spustit dříve, než je dokončeno, a proto mám více štěstí, když pozastavím mezistop astart.
  • Vypnutí wifi v uživatelském rozhraní; počkejte pár sekund; zapněte jej zpět

Zdá se, že žádný z těchto postupů neustále funguje, ale uvedl jsem je v pořadí nejpravděpodobněji úspěšných.

    
odpověděl redbmk 20.12.2016 17:07
2

Pracovní metoda Ubuntu 16.04:

Vytvořte službu:sudo nano /lib/systemd/system/wifi-resume.service

Služba volá program z:
/etc/init.d/network-manager

Vložte kód:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Poté povolte službu:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Toto vytváří symbolické odkazy do uvedených adresářů [Install] systému / etc / systemd / system a aktivuje službu

Poté můžete zkontrolovat stav pomocí:systemctl status wifi-resume.service

    
odpověděl cryptoboy 23.01.2017 01:59
1

Měl jsem stejný problém s bluetooth: Po pozastavení mého bluetooth myš nefungovala. Tak jsem odvodil řešení shora:

sudo nano /etc/systemd/system/bluetooth-resume.service

povolila novou službu

sudo systemctl enable bluetooth-resume.service

a upravili službu

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Také jsem se pokusil upravit ...

sudo nano /etc/bluetooth/main.conf

a změnil se

AutoEnable=true

BUT to nefungovalo pro "problém s obnovením" a neměl žádný vliv na nové zařízení bluetooth jakkoli!

    
odpověděl apos 31.08.2016 13:11
1

Měl jsem stejný problém na svém notebooku Dell Inspiron 15R s Ubuntu 16.04. Pro mě pracoval skript uvedený ve druhé odpovědi .

Po instalaci skriptu jsem vyzkoušel zavěšení pomocí příkazu v pravém horním menu a dokonce i zavření rtu a vyřešení problému.

Musím říci, že problém se střídal v jeho chování (to je, někdy to fungovalo před instalací skriptu).

    
odpověděl Alessandro D'lncal 18.01.2017 15:58
0

Pro mě bylo řešení spuštěno

nmcli nm sleep false

v terminálu

    
odpověděl tigerjack89 08.04.2017 13:01
0

Měl jsem stejný problém připojit se zpět k mému domovskému wifi po pozastavení. Vyzkoušeli různé jiné odpovědi, které by občas mohly fungovat, ale ne vždy.

Nakonec může být následující oprava umožněna důsledným připojením k síti wifi:

1) Upravte tento soubor:

sudo vim /etc/NetworkManager/NetworkManager.conf

2) Tímto přidáním:

[device]
wifi.scan-rand-mac-address=no
    
odpověděl Ray Vega 28.03.2018 08:09
0

Nyní pravděpodobně jednoduché

sudo apt update
sudo apt upgrade

by měl fungovat.

V mém případě mezi upgradovanými balíčky bylobcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.3) a po této aktualizaci funguje wifi znovu.

    
odpověděl Daniel 05.08.2018 07:08