Ubuntu 14.10 se nenainstaluje do virtualboxu

126

V současné době běžím systém Windows 8.1 x64 (problém sám o sobě, že nemohu smutně změnit ;-P) s nejnovější verzí VirtualBoxu (4.3.18 r96516). Podařilo se mi získat verzi serveru bez problémů, ale nemohu spustit verzi pro stolní počítače.

Mohu zavést nabídku a spustit proces (vyberte možnost instalace a / nebo pokusu) a dostane se přes initativní obrazovku pro načítání Ubuntu 14.10 (s progess "bar / tečky"), ale pak se dostaneme do nešťastná obrazovka zkreslených barev a to je všechno.

Moje hypotéza je, že ovladač / server displeje nefunguje s VirtualBoxem a to, co v podstatě vidím, je zobrazení v mizerném režimu (16colors @ 62x24), protože jsem schopen vidět dokonale jemnou obrazovku s kurzorovým ovládáním a všechno, a pak najednou jsem v té nepříjemné obrazovce. Myš se objeví (je to ošklivé hledisko a vyplnění celé obrazovky), ale nic jiného.

Zde je snímek obrazovky:

Zde je moje nastavení v albu (mohu přidat více, pokud je to žádoucí, ale vložil jsem to, co jsem považoval za nejrelevantnější):

    
dané MVit 24.10.2014 15:32

5 odpovědí

166

Stiskněte vpravo Ctrl + F1 (uvidíte shell) a potom Right Ctrl + F7 . V závislosti na konfiguraci Virtualbox použijte společně Left Ctrl + Alt namísto Right Ctrl

Je dobré pokračovat v instalaci.

Toto funguje tak, že vynucuje grafické vyrovnávací paměti jádra / X / XRandR, aby znovu detekoval monitor a zobrazil správné rozlišení.

    
odpověděl Gipnokote 24.10.2014 17:07
31

Musíte přepínat mezitty tak, aby host GUI mohl sám obnovit a správně rozpoznat prostředí. Toto je v současné době drobná chyba.

Doporučuji CTRL + ALT + F1 kbd> + F7 , ale pokud jste jako já, přijali ho hostitel a nikoli host.

Správná kombinace kláves pro přepnutí na tty1 při zaostřování na okna Guest je:

PRAVÁ CTRL + F1

a poté

PRAVÁ CTRL + F7

Všiml jsem si, že používám RIGHT CTRL , který je ten, který používá VirtualBox k vynechání zaostření VM.

Testováno s:

  • VirtualBox 4.3.18
  • Host Ubuntu 14.10 64-bit
  • Host Ubuntu 14.10 64-bit

Jiný způsob, jak to funguje, je jako Whaaaat. V nastavení VM v sekci Systém aktivujte zaškrtávací políčko Povolit EFI .

Ale také se ujistěte, že vaše čipset je také nastaven na PIIX3 , protože ICH9 nebude fungovat. Zanecháte vás na černé obrazovce.

Pokud je funkce EFI zapnuta, proces zavádění může trvat déle a obrazovka může zůstat černá, dokud se při zavádění nezobrazí logo Ubuntu. Pokud uvidíte Zavedení do zabezpečeného režimu ihned po spuštění VM, nebudete mít žádné potíže, pokud ne, pak počkejte trochu.

Všimněte si, že jsem testoval s 32 MB videa, 64 MB videa a 128 MB videa. Video nemá nic společného s tímto problémem ani v 32bitovém ani 64bitovém formátu.

    
odpověděl Luis Alvarado 27.10.2014 19:47
16

Povolte režim EFI.

Při zavádění systému se může zobrazit několik chyb. Nicméně jsou to neškodné a pro váš systém nic nedělají. Stále bude fungovat.

Pokud používáte režim EFI, ujistěte se, že čipová sada je nastavena na režim PIIX3, jako je tomu na obrázku. Mít je na ICH9 je ne zábava. PIIX3 je však výchozí, takže nemusíte nastavovat.

Zdá se, že Ubuntu a EFI se nyní navzájem líbí, takže pracují společně lépe než sami.

    
odpověděl Kaz Wolfe 28.10.2014 18:54
3

Změnil jsem čipovou sadu na ICH9, zakázal vnořené stránkování. To mi to vyřešilo.

    
odpověděl 88weighed 03.11.2014 11:00
2

Myslím, že je problém s 64bitovými verzemi. Ve stejném virtuálním stroji nefunguje 64 bit, ale pracuje 32. 128M video pracuje dobře 64 bitů.

    
odpověděl Think 24.10.2014 17:15