Jak deaktivuji klávesové zkratky F1 a F10 v terminálu gnome?

115

Jak mohu vypnout klávesové zkratky F1 (help) a F10 (oznámení)?

První, co potřebuji pro nástroj na obrazovce a druhý pro ukončenímc v konzoli.

V systémových nastaveních Klávesové zkratky nejsou k dispozici žádné takové vazby.

    
dané Marko Kevac 27.04.2011 15:55

14 odpovědí

107

11.04

Zakázání zástupce F1

  1. V gnome-terminálu otevřete Upravit ➜ Klávesové zkratky .

  2. Přejděte dolů na zástupce Nápověda / Obsah , klepněte na místo, kde se nachází "F1" a klikněte na Backspace :

Zakázání zástupce F10

  1. Nainstalujte soubor kompilátor konfigurace konfigurace .

  2. Otevřete Správce nastavení CompizConfig .

    • Klepnutím na Super otevřete příkaz Dash, zadejte příkaz "Compiz" a klikněte na tlačítko Enter
  3. Zadejte "jednotu" do položky Filtr a vyberte Ubuntu Unity Plugin .

  4. Klepnutím na tlačítko napravo od tlačítka otevřete první nabídku panelu a zrušte zaškrtnutí políčka Povoleno .

  5. Zakážete globální F10 zkratku, nyní zakázat zástupce F10 gnome-terminálu:

    • Klávesové zkratky ( Upravit ➜ klávesové zkratky) a v gnome-terminálu < zrušte zaškrtnutí volby Povolte klávesovou zkratku nabídky (implicitně F10)

  6. F10 je namapován na menubar_accel něčím v Ubuntu. Gnome? Metacity? Nejste si jisti, jaká je to přesná věc, kterou to ukradne, ale klíč to nedopadá do Eclipse.

    • Spusťte editor gconf, přejděte na / desktop / gnome / interface, pak přejděte dolů na menubar_accel a smažte hodnotu F10. [Odcizeno odtud]
odpověděl Isaiah 23.06.2011 20:52
44

Zakažte F10 v terminálu gnome v 12.04

Zadejte do konzoly:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Zavřete všechny terminálové relace. Nyní by měl fungovat tak, jak by měl (vmc).

odpověděl Paweł Gościcki 30.04.2012 21:25
23

spusťtegconf-editor a postupujte podle/apps/gnome-terminal/keybindings/help

Popis:

"Klávesová zkratka pro spuštění nápovědy Vyjádřená jako řetězec ve stejném formátu použitém pro soubory prostředků GTK + Pokud nastavíte volbu na speciální řetězec" zakázáno ", nebude k této klávesové zkratce.

    
odpověděl Rinzwind 21.08.2011 22:28
7

Jsem nový pro Linux a tento klíč F10 mě blázne. Všechny výše uvedené triky nefungovaly, ale nyní jsem našel řešení (pro Ubuntu 11.10 s klasickou pracovní plochou Gnome 3). V terminálu zadejte následující příkaz:

gsettings set org.gnome.desktop.interface menubar-accel ""

Pomocí editoru dconf lze zjistit, že F10 je opravdu pryč. Všimněte si, že tyto triky se zdají být velmi závislé na verzi Gnome / Ubuntu.

    
odpověděl gast128 29.11.2011 20:34
4

Pro ukončení příkazu mc (pomocí klávesy F10). Zakažte "Klávesa pro otevření nabídky prvního panelu" v modulu units compiz plugin (ccsm)

    
odpověděl kholis 29.04.2011 12:33
4

@kholis je správné pro vypnutí F10 v jednotce, ale pokud jste nováčkem jako já, potřebujete trochu víc informací, aby to fungovalo.

Pokud již není nainstalován, nainstalujte soubor compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Spusťte nově nainstalovaný správce nastavení a filtr pro "jednotu"

Upravte "Klávesa pro otevření první nabídky panelu", abyste ji deaktivovali nebo změnili na jiný klíč.

Nenašel jsem způsob, jak změnit F1.

odpověděl Ryan Sorensen 30.04.2011 19:36
3

Instrukce na adrese Odkaz (citované níže) funguje také v Ubuntu 11.04. (Zdá se, že F1 vypne jak na ploše, tak v terminálu, to znamená, že F1 neodesílá do terminálu ansi sekvenci, pokud to chce OP.)

  
  1. Přejít na Systém - Předvolby - Klávesové zkratky
  2.   
  3. Vytvořte novou zkratku. Naznačte jej "nic" a napište "false"   (bez uvozovek) v poli "příkaz". Stiskněte ok.
  4.   
  5. Přejděte na spodní část seznamu a najděte nový příkaz. Klikněte na tlačítko   na "Zakázáno" vpravo a stiskněte tlačítko F1.
  6.   
    
odpověděl David Andersson 22.08.2011 04:12
3

Můžete jej snadno deaktivovat pomocí CCSM (nainstalujte jej, pokud jej nemáte nainstalován ).

Pak přejděte na Desktop - > Plugin Unity Ubuntu - > Klávesa pro otevření nabídky prvního panelu a zakázání nebo změna na jinou klávesovou zkratku.

Poznámka : Zdá se, že tato metoda nefunguje v Unity2D.

    
odpověděl Binarylife 27.10.2011 00:03
2

Toto je tip pro uživatele Thnkpadu, zejména T60. Znovu zmáčkněte klávesu F1. To eliminuje nepříjemné vyskakovací okno nápovědy terminálu, když narazíte na F1. Často to děláte díky zábavnému umístění ESC na T60.

    
odpověděl ncmathsadist 03.12.2011 18:42
1

Pokud chcete změnit pouze v Gnome Terminalu , můžete kliknout na tlačítko Upravit > Klávesové zkratky v Terminálu.

    
odpověděl Jeremy Bicha 30.04.2011 20:37
1

Doporučuji použít F1 ​​jako zkratku pro něco jiného. Spouštím Tildu, terminál příkazového řádku ve stylu zemětřesení a výchozí zkratka je F1. Přepíše Nápovědu, takže jsem nikdy neměl pomoc při spuštění F1. Dokonce i když se vám Tilda moc nelíbí, znovu zaútočíte na F1, abyste se skrývali, je mnohem méně únavné než ukončení nápovědy po náhodném spuštění.

    
odpověděl titaniumtux 03.12.2011 20:23
1

12.04

F1 se nezdá, že dělá nic z krabice na 12.04
F10 vypadá, že simuluje pravé tlačítko myši
Takže v reakci na specifika této otázky není potřeba zakázat pomoc a upozornění.

Můžete je stále mapovat na něco jiného takto:
Mapování hot-keys v 12.04 je jednoduše provedeno pomocí widgetu Keyboard.

V jednotce spouštěče najdete klávesnici.
V okně, které se otevře, vyberte záložku zkratek a vlastní zkratky Klepnutím na tlačítko plus přidáte novou zkratku.

Název, který odpovídá funkci, kterou přiřazujete.
Zadejte příkaz, který chcete spustit v příkazu.

V pravé části okna klikněte na místo, kde se říká, že je zakázáno. Mělo by se přepnout na nový akcelerátor.

Nyní klikněte F10 Vlastní urgentní zkratka, kterou jste definovali, přepíše chování simulace pravým kliknutím. Tento příkaz můžete nastavit na hodnotuecho 'nope' > /dev/null, pokud chcete, aby váš F10 nic neudělal.

    
odpověděl RobotHumans 02.04.2012 19:50
1

12.04 bez jednotnosti - deaktivujte chování F1 a F11

Nainstaloval jsem Ubuntu 12.04 / 64 a od ní jsem Unity zcela odstranil po těchto pokynech . Mnoho nástrojů, které mění chování jednoty, proto nefungují. Konkrétně CCSM již "nevidí" klávesové zkratky.

Zjistil jsem, že metoda používající Edit-> klávesové zkratky v okně terminálu také nefungovala. Po trochu hraní jsem zjistil, že v sekci Klávesové zkratky byly dalejší než Klávesové zkratky , F1 a F11 byly stále definovány na příslušné klávesové zkratky.

To opravte,

  1. Klikněte na "F11" v pravém poli řádku, který definuje F11 jako celá obrazovka. Text se změní na "Nový akcelerátor ...".

  2. Zadejte další, méně nežádoucí, sekvenci kláves (jako alt-F11) a tato klávesová zkratka nahrazuje zástupce. Pokud někdo ví, jak napsat "nic", dejte nám vědět.

  3. Opakujte pro tlačítko F1.

odpověděl Wes Miller 20.11.2013 17:33
0

Ctrl + F1 také nefunguje. Řešení je stejné jako u Shift + F10. Nezapomeňte na středník jako na oddělovač!

Umístěte to do adresáře ~ / .config / gtk-3.0 / gtk.css:

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10";
     unbind "<control>F1";
}

* {
     gtk-key-bindings: NoKeyboardNavigation;
}
    
odpověděl egmont 16.03.2014 12:46